Header for large screens Header for small screens

Some content download methods may not be working as expected

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted Apr 25, 2023 - 20:04 UTC

Identified

Some attempts to download or access file data on Dropbox may not be working as expected.
Posted Apr 25, 2023 - 16:10 UTC
This incident affected: Website and API.