System Status

Dropbox is not working for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Sep 20, 2022 - 20:50 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 20, 2022 - 20:37 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 20, 2022 - 20:26 UTC
Investigating
Dropbox is not working for some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Sep 20, 2022 - 20:08 UTC
This incident affected: Website, Desktop Application, Mobile Application, API, Paper, Passwords, Capture, and Support Services.