System Status

Degraded experience on mobile Android users

Incident Report for Dropbox

Resolved

This incident has been resolved. Users are advised to download the latest version of the mobile application.
Posted 10 months ago. Jun 07, 2024 - 19:40 UTC

Update

We are continuing to work on a fix for this issue.
Posted 11 months ago. May 28, 2024 - 17:25 UTC

Identified

Some users may continue to have a degraded experience on mobile Android. The issue has been identified and a fix will be implemented.
Posted 11 months ago. May 24, 2024 - 20:21 UTC

Investigating

Some users may have a degraded experience on mobile Android. We are currently investigating this issue.
Posted 11 months ago. May 24, 2024 - 00:41 UTC
This incident affected: Mobile Application.