System Status

Dropbox website may not be working as expected
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Aug 19, 2022 - 01:51 UTC
Identified
The issue has been identified and a fix is in progress.
Posted Aug 18, 2022 - 21:40 UTC
Investigating
We're currently investigating page load issues on the Dropbox website. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Aug 18, 2022 - 15:41 UTC
This incident affected: Website, Paper, and Capture.