System Status

Admin Console buttons may not appear as expected for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Apr 27, 2023 - 21:22 UTC
Identified
Buttons in the Admin Console may not be displaying labels. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Apr 27, 2023 - 12:47 UTC
This incident affected: Website.