System Status

Previewing files may not be working as expected
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Sep 16, 2023 - 20:17 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 16, 2023 - 16:42 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 15, 2023 - 22:05 UTC
Investigating
File previews and thumbnails may not be displaying as expected for some users. We are actively addressing this issue and will provide another update shortly as we work to resolve it swiftly.
Posted Sep 15, 2023 - 20:04 UTC
This incident affected: Website, Desktop Application, and Mobile Application.