System Status

Dropbox desktop application may not be working as expected
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Apr 27, 2024 - 01:58 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 26, 2024 - 02:22 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 25, 2024 - 08:36 UTC
Identified
The problem has been identified as occurring when launching the Dropbox Desktop app without network connectivity. For most users, restarting the desktop app after connecting to a network should resolve the issue.
Posted Apr 24, 2024 - 16:24 UTC
Investigating
Dropbox desktop application may not be starting up as expected for some users. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Apr 24, 2024 - 15:30 UTC
This incident affected: Desktop Application.