System Status

Enterprise console may not be working as expected
Incident Report for Dropbox
Resolved
We’re back! The enterprise console should be up and running. Thanks for bearing with us.
Posted Apr 23, 2024 - 22:40 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 23, 2024 - 20:03 UTC
Investigating
The enterprise console may not be working as expected for some users. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Apr 23, 2024 - 18:53 UTC
This incident affected: Website.