System Status

The Activity page and activity reports are experiencing degraded performance
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Sep 22, 2021 - 18:04 UTC
Identified
We’re having some trouble with the Activity page, and also the associated reports on the Dashboard. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Sep 22, 2021 - 14:25 UTC
This incident affected: Website.