System Status

Some services are not working as expected
Incident Report for Dropbox
Resolved
The issue has now been resolved.
Posted Apr 24, 2023 - 20:57 UTC
Identified
Dropbox Paper, and some additional Dropbox features are suffering degraded availability at present.
Posted Apr 24, 2023 - 17:33 UTC
This incident affected: Website, Desktop Application, and Paper.