System Status

Dropbox is not available for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Jul 01, 2022 - 15:48 UTC
Investigating
Dropbox is not available for some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Jul 01, 2022 - 15:22 UTC
This incident affected: Website.