System Status

Dropbox is not working for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Jul 27, 2022 - 00:27 UTC
Investigating
Dropbox is not working for some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Jul 27, 2022 - 00:03 UTC
This incident affected: Website.