System Status

Previews may not be working as expected for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted May 22, 2023 - 22:20 UTC
Investigating
Previews may not be working as expected for some users. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted May 22, 2023 - 21:49 UTC
This incident affected: Website and Mobile Application.