System Status

Dropbox Paper is down for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Nov 12, 2019 - 17:53 UTC
Investigating
Dropbox Paper is down for some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Nov 12, 2019 - 17:22 UTC
This incident affected: Paper.