System Status

Users on some internet service providers are unable to connect to Dropbox servers
Incident Report for Dropbox
Resolved
We’re back! Everything should be up and running. Thanks for bearing with us.
Posted 6 months ago. Feb 27, 2019 - 18:51 UTC
Investigating
We're having some trouble connecting users on Spectrum (internet service provider) to Dropbox. This may extend to users on other internet service providers. We're looking into this and we'll share another update as soon as we can.
Posted 6 months ago. Feb 27, 2019 - 15:04 UTC
This incident affected: Website and Desktop Application.