Desktop Application performance issue
Incident Report for Dropbox
Resolved
Desktop Application performance should be back to normal. Thanks for bearing with us.
Posted 10 months ago. Feb 23, 2018 - 07:08 UTC
Identified
We’re getting closer to a solution. Our engineering team is working to resolve this problem. Check back for an update shortly.
Posted 10 months ago. Feb 23, 2018 - 06:57 UTC
Investigating
Our Desktop Application is currently being affected by a core performance issue. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted 10 months ago. Feb 23, 2018 - 06:39 UTC