System Status

Paper is not working as expected for users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Jun 02, 2023 - 05:25 UTC
Investigating
Paper is not working as expected for users. We are currently investigating this issue.
Posted Jun 02, 2023 - 00:15 UTC
This incident affected: Paper.