System Status

Camera Uploads via mobile may not be working as expected
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Apr 14, 2023 - 17:57 UTC
Investigating
Camera Uploads via mobile is not working as expected for some users. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Apr 14, 2023 - 16:03 UTC
This incident affected: Mobile Application.