www.dropbox.com experiencing issues
Incident Report for Dropbox
Resolved
Dropbox service has been fully restored. You may experience some latency with Dropbox tasks, but rest assured that normal performance will resume shortly. We apologize for any inconvenience this may have caused.
Posted over 1 year ago. Nov 16, 2015 - 18:01 UTC
Investigating
www.dropbox.com is currently experiencing issues. All users may be affected and see "Error 500" on the website.

Our engineering team is working to identify the root cause and implement a solution as quickly as possible.

We apologize for the inconvenience and will send an additional update in 30 minutes.
Posted over 1 year ago. Nov 16, 2015 - 17:37 UTC