System Status

Users may experience intermittent issues when accessing the website.
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Aug 08, 2023 - 21:49 UTC
Monitoring
Users should no longer be experiencing issues as of 18:30 UTC. We are continuing to monitor and will update shortly.
Posted Aug 08, 2023 - 19:13 UTC
Investigating
Users may experience intermittent issues when accessing the website. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Aug 08, 2023 - 18:30 UTC
This incident affected: Website.