System Status

Live support may be unavailable
Incident Report for Dropbox
Resolved
Live support is back up and running! Thanks for bearing with us.
Posted Oct 28, 2020 - 00:06 UTC
Monitoring
We've implemented a fix, but we're continuing to monitor the situation.
Posted Oct 27, 2020 - 23:56 UTC
Identified
We identified the root cause and the team is working to resolve the issue as soon as possible.
Posted Oct 27, 2020 - 23:26 UTC
Investigating
We're currently experiencing issues with our live support services (phone and chat). We're aware of the issue and are currently investigating.
Posted Oct 27, 2020 - 20:42 UTC
This incident affected: Support Services.