System Status

Dropbox may not be working as expected for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Jul 27, 2022 - 17:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2022 - 16:13 UTC
Investigating
Viewing shared files or folders may not be working for some users. We're working to fix the issue as quickly as possible. We'll share another update shortly.
Posted Jul 27, 2022 - 15:47 UTC
This incident affected: Website.