Admin Console Service Disruption
Incident Report for Dropbox
Resolved
Dropbox services are fully restored. While you may experience some delays with Dropbox features, you should soon be back enjoying Dropbox fully. Thank you for bearing with us.
Posted about 1 year ago. Sep 20, 2017 - 21:25 UTC
Identified
Dropbox is currently experiencing a service disruption. The incident is due to an issue that arose during a routine operation, which we have identified and are working to resolve promptly.

We appreciate your patience while our engineering team works on accelerating recovery. We will send an additional update in 30 minutes.
Posted about 1 year ago. Sep 20, 2017 - 21:04 UTC
Investigating
Dropbox is currently experiencing a service disruption.

Our engineering team is working to identify the root cause and implement a solution as quickly as possible. Some users may be affected.

We apologize for the inconvenience and will send an additional update in 30 minutes.
Posted about 1 year ago. Sep 20, 2017 - 20:24 UTC