System Status

Issues logging into Dropbox.
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Sep 22, 2023 - 20:45 UTC
Investigating
We are aware of issues logging in to Dropbox and are investigating.
Posted Sep 22, 2023 - 19:42 UTC
This incident affected: Website.