System Status

Dropbox blog and help center may not be working as expected
Incident Report for Dropbox
Resolved
Our Help Center, Blog and any other affected sites have fully recovered from any downtime briefly experienced.
Posted Apr 28, 2022 - 22:33 UTC
Investigating
Dropbox blog and help center may appear unavailable. We're working to resolve the issue.
Posted Apr 28, 2022 - 22:24 UTC
This incident affected: Website.