System Status

Google Cloud integration errors
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Jan 13, 2022 - 15:41 UTC
Investigating
We are investigating an issue with our Google Cloud integration. We’ll share another update shortly.
Posted Jan 12, 2022 - 22:34 UTC
This incident affected: Website and Desktop Application.