Header for large screens Header for small screens

Dash Chat might not be working for some users

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted May 05, 2025 - 21:30 UTC

Investigating

Dash Chat might not be working for some users. We're working to fix the problem as quickly as we can.
Posted May 05, 2025 - 18:26 UTC
This incident affected: Dash.