Desktop Client, Mobile and API Service Disruption
Incident Report for Dropbox
Resolved
Dropbox service has been fully restored. You may experience some latency with Dropbox tasks, but rest assured that normal performance will resume shortly. We apologize for any inconvenience this may have caused.
Posted over 1 year ago. May 23, 2017 - 20:24 UTC
Update
Dropbox is currently experiencing a service disruption. We are working to identify the issue and resolve promptly. We appreciate your patience while our engineering team works on accelerating overall recovery.
Posted over 1 year ago. May 23, 2017 - 20:06 UTC
Investigating
Dropbox is currently experiencing a service disruption.
Our engineering team is working to identify the root cause and implement a solution as quickly as possible.
We apologize for the inconvenience and will send an additional update in 30 minutes.
Posted over 1 year ago. May 23, 2017 - 19:40 UTC