Header for large screens Header for small screens

Some users are having issues accessing Dropbox

Incident Report for Dropbox

Resolved

We’re back! Thanks for bearing with us.
Posted Jun 18, 2019 - 22:35 UTC

Investigating

Some users are having issues accessing Dropbox. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Jun 18, 2019 - 21:32 UTC
This incident affected: Website, Desktop Application, Mobile Application, API, and Paper.