System Status

Dropbox may be unavailable for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Oct 28, 2021 - 17:22 UTC
Update
We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Oct 28, 2021 - 16:50 UTC
Investigating
We are currently investigating the issue.
Posted Oct 28, 2021 - 15:18 UTC
This incident affected: Website, Desktop Application, and Mobile Application.