System Status

Dropbox is down

Incident Report for Dropbox

Resolved

We’re back! Everything should be up and running. Thanks for bearing with us.
Posted 7 years ago. Oct 14, 2017 - 13:22 UTC

Update

Fixing this issue is taking longer than expected. We've partially recovered and hope to be fully back up soon.
Posted 7 years ago. Oct 14, 2017 - 13:16 UTC

Update

We’re getting closer to a solution. Our engineering team is working to resolve this problem as quickly as possible.
Posted 7 years ago. Oct 14, 2017 - 12:49 UTC

Identified

Our engineers are working to fix this problem. We should be back up soon. Check back for an update shortly.
Posted 7 years ago. Oct 14, 2017 - 12:26 UTC

Investigating

All parts of the Dropbox platform are currently down for most users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted 7 years ago. Oct 14, 2017 - 11:52 UTC