System Status

Some features are not working correctly on the Dropbox Android app
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Nov 11, 2020 - 18:40 UTC
Investigating
We’re having some trouble with the Dropbox Android app. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Nov 11, 2020 - 18:30 UTC
This incident affected: Mobile Application.