Banner
Dropbox Service Disruption
Incident Report for Dropbox
Resolved
Dropbox service has been fully restored. You may experience some latency with Dropbox tasks however normal performance will resume shortly. We apologize for any inconvenience this may have caused.
Posted 14 days ago. Sep 06, 2017 - 10:09 UTC
Investigating
Dropbox is currently experiencing a service disruption.

Our engineering team is working to identify the root cause and implement a solution as quickly as possible. All users may be affected

We apologize for the inconvenience and will send an additional update soon.
Posted 14 days ago. Sep 06, 2017 - 10:01 UTC