Images not loading in Dropbox Paper

Incident Report for Dropbox

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 12:49 UTC

Investigating

We are aware that Images and the preview of an images are not loading in Dropbox Paper.
Posted Oct 14, 2025 - 09:06 UTC
This incident affected: Paper.