www.dropbox.com experiencing issues
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted almost 2 years ago. Nov 12, 2015 - 00:49 UTC
Monitoring
Dropbox service has been restored. Users should no longer see '500' errors when accessing www.dropbox.com. We apologize for any inconvenience this may have caused.
Posted almost 2 years ago. Nov 11, 2015 - 21:43 UTC
Investigating
Users may see '500' error pages when using the Dropbox website. All users may be affected. Our engineering team is working to identify the root cause and implement a solution as quickly as possible.

We apologize for the inconvenience and will send an additional update in 30 minutes.
Posted almost 2 years ago. Nov 11, 2015 - 21:26 UTC