System Status

Dropbox is not working for some users
Incident Report for Dropbox
Resolved
This incident has been resolved. Thank you for your patience!
Posted Aug 31, 2022 - 16:09 UTC
Investigating
Dropbox is not working for some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Aug 31, 2022 - 15:33 UTC
This incident affected: Website.