System Status

Dropbox may not be working as expected
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Mar 10, 2023 - 21:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2023 - 21:12 UTC
Investigating
Dropbox and some associated services may be suffering degraded performance.
Posted Mar 10, 2023 - 21:08 UTC
This incident affected: Website, Desktop Application, Mobile Application, and API.