System Status

Dropbox is not working for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Jun 09, 2022 - 13:41 UTC
Investigating
We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Jun 09, 2022 - 13:30 UTC
This incident affected: Website.