System Status

Some Dropbox services may not be working as expected
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted May 10, 2022 - 23:10 UTC
Identified
Some Dropbox services are working slower than expected. We are working to restore full availability.
Posted May 10, 2022 - 22:44 UTC
This incident affected: Website, Desktop Application, Mobile Application, and API.