www.dropbox.com Service Disruption
Incident Report for Dropbox
Resolved
Dropbox service has been fully restored. You may experience some latency with Dropbox tasks, but rest assured that normal performance will resume shortly. We apologize for any inconvenience this may have caused.
Posted about 1 year ago. May 17, 2016 - 14:48 UTC
Investigating
Dropbox is currently experiencing a service disruption. Some users may be unable to access www.dropbox.com.

Our engineering team is working to identify the root cause and implement a solution as quickly as possible. We apologize for the inconvenience and will send an additional update in 30 minutes.
Posted about 1 year ago. May 17, 2016 - 14:39 UTC