System Status

File Requests may not be working as expected
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Apr 27, 2023 - 07:22 UTC
Investigating
File Requests are not working as expected for some users. We are investigating the problem and will update shortly.
Posted Apr 26, 2023 - 23:20 UTC
This incident affected: Website.