System Status

Some features are not working correctly on Paper
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Sep 08, 2021 - 17:21 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 08, 2021 - 16:35 UTC
Investigating
We’re having some trouble with Paper document invites. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Sep 08, 2021 - 16:34 UTC
This incident affected: Paper.