System Status

Phone support may not be working as expected for some Team Admins
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Jun 22, 2024 - 05:46 UTC
Investigating
Calling support may not be working as expected for some Team Admins. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Jun 22, 2024 - 01:47 UTC
This incident affected: Support Services.