System Status

Desktop Application Performance Issue
Incident Report for Dropbox
Resolved
We've resolved the issue! Desktop application performance should be coming back to normal. Thanks for bearing with us.
Posted almost 2 years ago. Oct 17, 2017 - 16:19 UTC
Identified
We continue to have some trouble with the desktop application, mostly affecting performance. Our engineering team is working to resolve the problem.
Posted almost 2 years ago. Oct 17, 2017 - 15:45 UTC
Update
We're still working to fix this problem. The desktop application should be back up soon. We'll share another update shortly.
Posted almost 2 years ago. Oct 17, 2017 - 15:14 UTC
Investigating
The desktop application is down for most users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted almost 2 years ago. Oct 17, 2017 - 14:45 UTC