Banner
Planned Site Maintenance
Incident Report for Dropbox
Resolved
Maintenance has concluded and Dropbox service has been fully restored. You may experience some latency with Dropbox tasks, but rest assured that normal performance will resume shortly. We apologize for any inconvenience this may have caused.
Posted about 2 years ago. Nov 21, 2015 - 19:28 UTC
Monitoring
Dropbox will be undergoing planned site maintenance for about two hours. For this period, you will be able to access your account and data, but will not be able to make changes. Your data will be safe throughout the maintenance, and will be available again right after this process ends.
Posted about 2 years ago. Nov 21, 2015 - 16:50 UTC