System Status

Dropbox is not working as expected for some users
Incident Report for Dropbox
Resolved
This incident has been resolved
Posted Sep 14, 2022 - 01:41 UTC
Monitoring
A fix has been implemented and we are monitoring the results
Posted Sep 13, 2022 - 23:46 UTC
Investigating
We're having some trouble with our services currently. We're working to fix the problem as quickly as we can. We'll share another update shortly.
Posted Sep 13, 2022 - 19:14 UTC
This incident affected: Website.