Paper & Showcase performance issues
Incident Report for Dropbox
Resolved
Paper’s performance has returned to normal. Thank you for bearing with us over the last few days and we apologize to those who were impacted. In the coming days, we’ll communicate the steps we’re taking to help address issues like this in the future. Thanks again for your patience.
Posted 6 months ago. Jun 21, 2018 - 01:44 UTC
Update
We know that fixing Paper is taking longer than expected and that Showcase users may be experiencing issues as well. Our engineering team is making progress and we aim to have an expected time to resolution soon.

We appreciate your patience and will provide additional updates as soon as we can.
Posted 6 months ago. Jun 20, 2018 - 16:20 UTC
Update
We’re still working to get Paper back to its normal state. We know this is impacting users who rely on Paper and we appreciate everyone’s patience. Please continue to check our status page for the latest updates.
Posted 6 months ago. Jun 20, 2018 - 00:53 UTC
Update
We're getting there, folks! Our Engineers have identified the issue and we're working towards a solution. The bad news is that it's likely going to take a while for all systems to stabilize and for performance to return to normal.

Check back in soon and thanks for bearing with us!
Posted 6 months ago. Jun 19, 2018 - 09:02 UTC
Update
Paper is currently experiencing performance issues, but we’re beginning to see improvements and are monitoring the situation closely.

We appreciate your patience while our engineering team continues to work on a solution. We’ll share another update as soon as we can.
Posted 6 months ago. Jun 19, 2018 - 03:51 UTC
Update
We're still experiencing performance issues with Paper. Our engineering team is continuing to work on a solution and we hope to have the problem resolved as soon as possible.
Posted 6 months ago. Jun 18, 2018 - 21:26 UTC
Monitoring
Paper is currently experiencing performance issues. Our engineers are investigating the issue and we’re monitoring the situation. We’ll share another update as soon as we can.
Posted 6 months ago. Jun 18, 2018 - 16:35 UTC
This incident affected: Paper.