System Status

Saving files from external apps into the Dropbox Android app might not be working for some users
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Jun 23, 2022 - 16:07 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 22, 2022 - 14:34 UTC
Investigating
Saving files from external apps into the Dropbox Android app might not be working for some users. We're working to fix the problem as quickly as we can.
Posted Jun 21, 2022 - 20:12 UTC
This incident affected: Mobile Application.