System Status

Some features are not working correctly on our website
Incident Report for Dropbox
Resolved
This incident has been resolved.
Posted Dec 08, 2021 - 19:32 UTC
Investigating
We’re having some trouble with our website . We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Dec 08, 2021 - 19:14 UTC
This incident affected: Website.